View: 409|Reply: 9

Adeept android app

[Copy link]

3

Threads

16

Posts

91

Credits

Registered member

Rank: 2

Credits
91
Post time 2020-1-13 03:30:28 | Show all posts |Read mode
Has anyone got this working? I enter the IP address and 10123 as port and press connect and the damn thing disappears Mars rover with raspberry pi 4
Reply

Use magic Report

6

Threads

47

Posts

651

Credits

Senior member

Rank: 4

Credits
651
Post time 2020-1-13 14:15:25 | Show all posts
Edited by 1501915115 at 2020-1-13 02:16 PM

Reply

Use magic Report

6

Threads

47

Posts

651

Credits

Senior member

Rank: 4

Credits
651
Post time 2020-1-13 14:15:35 | Show all posts
The app disappears. It may be that the IP address of the Raspberry Pi you are trying to connect to is incorrect, or the mobile WIFI is not connected to the router. It means that your mobile app and Raspberry Pi are not connected successfully
Reply

Use magic Report

0

Threads

69

Posts

412

Credits

Website Editor

Rank: 8Rank: 8

Credits
412
Post time 2020-1-13 17:51:35 | Show all posts
Connect to the Raspberry Pi using putty and run appserver.py manually. You can run it using the command
sudo python3 adeept_picar-bv2.0/server/appserver.py
Then you can try to connect the Raspberry Pi with the app.
Reply

Use magic Report

3

Threads

16

Posts

91

Credits

Registered member

Rank: 2

Credits
91
 Author| Post time 2020-1-13 22:02:53 | Show all posts
pi@raspberrypi:~/adeept_picar-bv2.0/server $ sudo python3 appserver.py
192.168.1.93
waiting for App connection...
No the app still just disappears
Reply

Use magic Report

3

Threads

16

Posts

91

Credits

Registered member

Rank: 2

Credits
91
 Author| Post time 2020-1-13 22:28:21 | Show all posts
Hmm seems the port is 10223 not 10123 as in the instructions not that it helped the gamepad type interface that appeared has no effect at all on the rover
Reply

Use magic Report

0

Threads

3

Posts

16

Credits

Newbie

Rank: 1

Credits
16
Post time 2020-9-9 23:46:03 | Show all posts
pi@raspberrypi:~ $ sudo python3 adeept_rasptank/server/appserver.py
Loading...
Setting up server...
Traceback (most recent call last):
  File "adeept_rasptank/server/appserver.py", line 17, in <module>
    servo.servo_init()
AttributeError: module 'servo' has no attribute 'servo_init'

this is the error i receive when trying to run appserver.py
Reply

Use magic Report

1

Threads

2

Posts

9

Credits

Newbie

Rank: 1

Credits
9
Post time 2020-9-10 04:07:52 | Show all posts
Sadly I wouldn't expect any replies. I posted yesterday and haven't had any replies. (Picar headaches)
Reply

Use magic Report

0

Threads

3

Posts

16

Credits

Newbie

Rank: 1

Credits
16
Post time 2020-9-11 00:26:56 | Show all posts
1539263851 replied at 2020-9-10 04:07 AM
Sadly I wouldn't expect any replies. I posted yesterday and haven't had any replies. (Picar headache ...

I managed to control the robot via the GUI instructions on the manual if you want to try it!

Reply

Use magic Report

0

Threads

23

Posts

73

Credits

Registered member

Rank: 2

Credits
73
Post time 2020-9-12 18:14:08 | Show all posts
If you want to control the robot with a mobile phone, it is recommended to run the webServer.py program, and then visit the "Raspberry Pi IP + port number 5000" on the Google browser on the mobile phone, for example "192.168.3.230:5000"
Reply

Use magic Report

You have to log in before you can reply Login | Sign Up

Points Rules