View: 223|Reply: 4

servo shaking in Mars Rover PiCar-B

[Copy link]

1

Threads

2

Posts

33

Credits

Newbie

Rank: 1

Credits
33
Post time 2020-1-19 20:09:59 | Show all posts |Read mode


i have purchased a mars rover picar as a first robotics project. it's a very nice and well built car, though i am experiencing a serious problem: servo shaking

when controlling camera to look left/right, up/down, servos are moving back and forth from time to time and sometimes it keeps shaking.
all servos have some problem.

is this an electrical problem with motor hat ?

car is powered by 3350mAh 18650 batteries

thank you

Reply

Use magic Report

3

Threads

16

Posts

91

Credits

Registered member

Rank: 2

Credits
91
Post time 2020-1-20 20:01:47 | Show all posts
I have the same problem it seems the advice to manually centre the servo arm can damage the gears I've ordered a new servo and plan to set that electronically
Reply

Use magic Report

1

Threads

2

Posts

33

Credits

Newbie

Rank: 1

Credits
33
 Author| Post time 2020-1-22 23:06:24 | Show all posts
1578237737 replied at 2020-1-20 08:01 PM
I have the same problem it seems the advice to manually centre the servo arm can damage the gears I' ...



you might be right, but is not the gear damaged maybe internal feedback mechanism is affected (i don't know exactly how this works internally)
please let me know if you have success with that.

though i am suspecting some kind of electric defect in motor hat that affects pwm signal.

i also noticed that ws2812 leds are not working properly neither.
in your case do ws2812 leds work ?

Reply

Use magic Report

3

Threads

16

Posts

91

Credits

Registered member

Rank: 2

Credits
91
Post time 2020-1-23 06:55:24 | Show all posts
It seems the software on this is a real dogs dinner my first attempt with adeept_pi_car was not good changing to adeept_picar_b2.0 (available on github was better but I've tried it on both windows and linux machines and the led's work on linux but not windows and the radar scan works on windows but not linux. the new problem is the servo powering the steering locks on a right turn and the motor keeps on running even after I've shut down the Pi through ssh. The base problem seems to be the function that should write the ip.txt file as far as I can see it doesn't work at all
Reply

Use magic Report

1

Threads

11

Posts

35

Credits

Newbie

Rank: 1

Credits
35
Post time 2020-1-29 19:34:22 From the mobile phone | Show all posts
After I connected using client.py..camera servo got super hot-now dead. Other 2 servos ok but left=right and right=left. I triple checked installation is correct. Anybody else see that?
Reply

Use magic Report

You have to log in before you can reply Login | Sign Up

Points Rules