View: 34|Reply: 1

RaspTank - My First Summary Report

[Copy link]

1

Threads

1

Posts

17

Credits

Newbie

Rank: 1

Credits
17
Post time 2021-1-25 02:49:48 | Show all posts |Read mode
Edited by 1611512717 at 2021-1-25 03:12 AM

Dear Adeept Team,

Dear Ladies and Gentlemen,

First of all... let me say Thank You for this product. Please excuse my poor english, i am from Austria and speak german generally but i got a little IT experience so i will try my best.

Well, I am really positively surprised about this kit and how you developed and provided the construction of the body parts and the placement of the components of this product RaspTank. The quality and precision of the components and parts itselfs is pretty good as well - for the price level of the product. And esp. to use screws, nuts and standoffs in M-standard, instead of anything else, is very positive from my point of view, because they can all be easily replaced and adapted in case if needed.

The good news first: my RaspTank is now finally set up and running.

But to be honest, I still have and have had a few issues while assembling the construction and the setup and made some of the steps at least twice or even more often - sometimes my fault, sometimes surrounding issues. The not working original (RPi v.1.3) cam took me quite a while to identify and fix it by replacing it with one special-with-angle cam i had originally bought for another project. The problem to find out the issue with the cam was that the cam module itself is working (red led) but the cmos sensor or the so called "sunny" connection is not working. So the red led was turning on like it should but it took no picture. Because of this fact I was thinking quite a while that it's any other issue but not the cam. I tried a lot, mostly twice and also switched between the raspberry Pi 3B and a Pi 4B (4GB) model on my way to victory.

The Tutorial pdf you provided is pretty good but the troubleshooting section is not very long. What i was missing as well: cables ...no cables on the pictures, no word about how to handle with them - where to put them in which order, or any hint would have been nice ;)
After assembling my RaspTank in a couple of very nice hours in a kind of flow, I was facing the problem that after turning it on, it was not auto starting the software due to any reason. And when I manually started the webServer.py I got error prompt like:

   "....
  cv2.error: OpenCV(3.4.3)..... (-10:Unknown error code -10) Raw image
  encoder error: Empty JPEG image (DNL not supported)..."

...what is different to the prompt you get if the cam is not connected or connected wrong. So I started to look deeper into your forum searching "rasptank" to get more infos and maybe find the same problem and or solution(s). After updating the OpenCV library like noted in the troubleshooting section in the tutorial, same problem. What i found then in another posting about cam problems was this your advice:

  After the confirmation is complete, please run the command in the terminal:
  "raspistill -t 1000 -o image.jpg",
  If the camera is installed correctly, the program will not go wrong,
  After running the command "ls", a picture of image.jpg can be viewed.

So I knew from this point that the cam must be the problem. Even checking the "sunny" connection on the cam module itself after getting an error prompt after the "raspistill" command, was not fixing the problem - I checked the tiny plug ...it's clean, looking ok (checked pins as far as possible with magnifying glass) and made "click" but still not working - red led on module turning on/off but no picture. Guess the cmos or its connection is broken. I finally got the confirmation after connecting my "fish-eye-cam" instead of the original and fixing it outside the casing with tiny cable ties.
After restarting the RaspTank, webServer.py autostarted like it originally should and the breathing light effect made me smile very bright and feeling little bit like a kid again with its favorite new toy ...hihi

Now I started the client in my laptop's browser and the control interface showed up with a picture and the control buttons like it should. In the Firefox Browser the live view is not working but in chrome it is - what i found out after a few minutes wondering about the screwdriver i removed still in the picture. lol

After about five minutes online and testing the controls, I realized the reversed for / backward command and some issues with the robot arm and the camera servos ...seem to be reversed or some kind of software issue. I checked the right connection order of the servos twice.

While realizing this problem i was facing another one - heat ...the cpu temperature displayed in the webcontrol interface was rising very fast.
When it was coming to reach 70 degrees C i turned off the RaspTank to avoid any damage to the Raspberry Pi 3B i was using at this time.

Checking the status of the 18650 akkus by puting one of them into the charger to see its below 25% made me charge them but also wondering about a missing display about the charge status and if there is a way to check it while inside.

Still I was focused on the heat problem. The RPi 3B i was using had a passive cooling body (alu) but even with it i ran into overheat very fast after maybe 5-7 minutes ...so i tried without ...i tried to lay the cables in another way but no effect.

Then I gave the RPi 4B a chance - hoping that the higher cpu power and the much bigger ram of 4GB can handle the software better - and i was right. I was reading about problems using a 4B but it was working from the first moment (with my fish-eye-cam). It's better now but still I am running into overheats (70+ degrees Celsius) - just a question of time even when doing nothing. After 10 Minutes on average I gotta turn off - even if the akkus are still fine and I realized as well that with the Pi4B they don't last as long as with the Pi3B naturally. The Fish-eye-cam I have now is using more energy as well I guess. The RPi4B I am using now is passive cooled just on the cpu. I put it a little offset so it fits with the Motor-Hat. From using the Pi3B I know that it's better to cool at least the cpu (others are not possible due to missing space).

However - my RaspTank is now still facing heat problems. As well as the issues with the reversed fw/bw control and the mixed up camera and robot arm servos.
I saw a post with a similar problem with the mixed up servos and there you propose to change the servo.py if i remember right. Really!? Could you please just provide a fixed servo.py or do i really gotta make these changes manually!?

Also the fish-eye-cam i am using now is probably making issues to the motion detection software, because the position as well as the perspective and the angle view of the cam is different to the original for sure. But I am trying to test this and some other things at the moment.

As well, I made photos and videos from all the process ...from opening the package until the first run. To not stress your servers, i decided to let them all on my public facebook profile. Most of them can be found in several last posts and as well in a featured photo story called RaspTank what all can be found under: https://www.facebook.com/da.michl.33

Or just search in facebook for "Da Michl" or "Da Michl 33" and you should get to my real public profile somehow.
I can send parts of the photo / video story or the whole material if somebody wants it.

So ...now ...i got some remaining questions for the final:

- How are we gonna deal with the not working original v.1.3 RPi Cam!?

- Any way to avoid overheating - maybe over the raspbian system software or its way handling your software?

- Any way to display the remaining akku charge in percentage or volt online in web interface or in rpi system (terminal)?

- Is your software also running on a minimal / light system on the raspberry - maybe another distribution, raspian light or ...i dunno ...ever tried kali or any other distribution? (Maybe this could result in less heat somehow)

- Why the motors are shaking when booting without logo or direct into cli instead onto the desktop - and why is the desktop needed (boot into cli is not working - its booting but no access over web interface; this was also one of my ideas to avoid fast overheat)

- After I finished assembling, I wondered a little bit about the amount of parts left. Thanks for giving +1 in case. But the single M3x18 screw is still in its bag and I also wonder about what the 3 pole cable (white,red,black) with a strange adapted plug on one side is originally for!?

Maybe this My First Summary Report about the RaspTank is useful to other people as well, so i decided to post it in the public Adeept forum as well.

Remaining with kind regards,

Da Michl


Reply

Use magic Report

19

Threads

214

Posts

747

Credits

Senior member

Rank: 4

Credits
747
Post time 2021-2-4 18:34:34 | Show all posts
You can reduce the load on Raspberry Pi by not using ws2812 lights  The 3-pin cable is the extension cable of the steering gear, which is used when the built-in cable of the steering gear is not long enough.
Reply

Use magic Report

You have to log in before you can reply Login | Sign Up

Points Rules