View: 33|Reply: 0

Raspclaw camera issue

[Copy link]

1

Threads

1

Posts

9

Credits

Newbie

Rank: 1

Credits
9
Post time 2021-4-2 02:05:49 | Show all posts |Read mode
Edited by 1617295242 at 2021-4-2 02:07 AM

Hi all,

I'm new with robotics and Raspclaw is my first robot. I have problem with camera there are errors during command:
raspistill -t 1000 -o image.jpgpi@raspberrypi:~/adeept_raspclaws/server $ raspistill -t 1000 -o image.jpg
mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn't be enabled
mmal: main: Failed to create camera component
mmal: Only 76M of gpu_mem is configured. Try running "sudo raspi-config" and ensure that "memory_split" has a value of 128 or greate

and when I tried to run app.py:
Starting camera thread.
VIDEOIO ERROR: V4L2: Pixel format of incoming image is unsupported by OpenCV
Unable to stop the stream: Device or resource busy
VIDEOIO ERROR: V4L: can't open camera by index 0
Exception in thread Thread-4:

I double check flex cable and tried to open web controller where camera was on, so there is a signal from camera to RPi:Someone maybe knows how to solve it or at least what is the cause? is this a fault of camera or cable?
I'm looking at stackoverflow and some RPi forums but none of solutions which I found worked yet. I will try to reinstall RPi tomorrow and see if anything changed




Reply

Use magic Report

You have to log in before you can reply Login | Sign Up

Points Rules