View: 148|Reply: 1

RaspClaws erratic behaviour

[Copy link]

2

Threads

6

Posts

36

Credits

Newbie

Rank: 1

Credits
36
Post time 2022-5-16 08:02:44 | Show all posts |Read mode
I just finished assembling my Robot using a Raspberry Pi 4B with 4gb ram, using a new 32gb Sandisk SD card and the Adeept image. My first issue noted was that the camera servo motions for UP/DOWN were reversed. I found that in the webServer.py file I could reverse the servo directions by changing a "1 to -1" for the appropriate functions. My GAIT motions are normal Forward, Reverse, Left and Right but I am seeing that the servo connected to port pwm2, does not respond or move correctly or at all. When the RaspClaw is left IDLE, that servo will sporatically move from one extreme to the other, it will also cause/bind up the servos at ports pwm0 and pwm4. The RaspClaw will also restart itself and reboot the robot; the LEDs do not turn OFF during this reboot/restart.

i am unable to upload video
Reply

Use magic Report

0

Threads

19

Posts

51

Credits

Administrator

Rank: 9Rank: 9Rank: 9

Credits
51
Post time 2022-5-24 11:38:03 | Show all posts
1. All servos of the robot need to be adjusted to the middle position (90°) from the initial angle before installation. Please confirm whether the camera servo is adjusted to the initial position.

2. The camera structure on the top may be installed incorrectly, which may cause the reverse control of the servo.

3. The robot restarts may be due to insufficient battery power causing the Raspberry Pi to restart. Please fully charge the battery.
The LED is always on because the signal received by the LED has been determined, and the power supply supplies power to the LED, so the LED remains on.
Reply

Use magic Report

You have to log in before you can reply Login | Sign Up

Points Rules