Reasons and solutions for error prompting when upload programs to Arduino nano with the new version of Arduino IDE 1.87 compiler.

Reasons and solutions for error prompting when upload programs to Arduino nano with the new version of Arduino IDE 1.87 compiler.

You will find that the program cannot be uploaded if upload code to remote nano with the new version of the Arduino IDE 1.8.7 or later. This is because the IDE’s default nano board uses the new BootLoader. The BootLoader of the Nano board we used during the product transition will be slower to update, and the functions of the Nano board has not changed. The new IDE also provides a solution: click “Tools” - “Processor: “ATmega328P (Old Bootloader)” - processor selection “ATmega38P (Old BootLoader)”. The above problem can be solved.

As follow:

Leave a Reply