View: 90|Reply: 4

Adeept Wheeled Robot ADR014 - cannot drive slowly

[Copy link]

2

Threads

4

Posts

26

Credits

Newbie

Rank: 1

Credits
26
Post time 2024-6-11 00:26:56 | Show all posts |Read mode
Edited by 1718036536 at 2024-6-11 04:47 PM

Hi - I just finished assembling my ADR014 - and all components seem to work.
Just one question: it drives fine through the web interface as long as the slider for 'speed' is high enough, but as soon as it like half-way or lower, the motors do a bit of a screeching sound, but don't reliably turn.

Is this normal or somehow a know problem?

Thank you!
Axel
Reply

Use magic Report

0

Threads

1

Posts

4

Credits

Newbie

Rank: 1

Credits
4
Post time 2024-6-13 10:08:38 | Show all posts
If you've double-checked all of these potential issues and the problem persists, I would recommend reaching out to the manufacturer or a support community for the ADR014 to see if this is a known issue with a recommended solution quordle
Reply

Use magic Report

0

Threads

1

Posts

4

Credits

Newbie

Rank: 1

Credits
4
Post time 2024-7-9 14:53:19 | Show all posts
Sometimes, certain motors or motor controllers can produce audible noise or struggle to operate smoothly at lower PWM (Pulse Width Modulation) frequencies or lower duty cycles. This could lead to the screeching sound and erratic behavior you're observing.
Reply

Use magic Report

0

Threads

7

Posts

35

Credits

Newbie

Rank: 1

Credits
35
Post time 7 day(s) ago | Show all posts
Hello,


You can control the motor separately. According to the prompts in the tutorial "11 How to Control DC Motor", you can modify the speed settings in the code and see if your problem occurs.


Because when a motor needs to overcome a certain weight load, there is indeed a speed threshold (PWM controlled duty cycle) below which the motor may not start or rotate, while above this value it can rotate normally.



Best!

  ------------------------------------------
Adeept Tech Support Team
Adeept Technology Co., Ltd.
E-mail: support@adeept.com
Web: www.adeept.com





Reply

Use magic Report

0

Threads

7

Posts

35

Credits

Newbie

Rank: 1

Credits
35
Post time 7 day(s) ago | Show all posts
Hello,


You can try the following methods to solve this problem:
1. Only connect Raspberry Pi, Robot HAT, and Camera


2. Run "sudo python3 adept_raspclaws/setup. py" from the Raspberry Pi command line to install the dependency libraries.


3. After installation, Raspberry Pi will restart. After successful configuration, Raspberry Pi will automatically run the webServer. py program, which needs to be manually terminated in order to proceed with the following steps.
Run "sudo kill python3" on the Raspberry Pi command line to terminate the automatically running program.


4. Enter the command: "raspistill-t 1000- o image.jpg". Under normal circumstances, Raspberry Pi will take a photo named image.jpg, which can be viewed through "ls". If an error occurs during operation, please check if the camera is installed correctly until this command can run successfully.


5. Then run "sudo python3 adept_raspclaws/server/webServer. py"


6.If there are no errors when running the program, please use Google Chrome to enter the web control interface through "Raspberry Pi IP address"+": 5000". At this time, you can see the Raspberry Pi camera screen on the web control interface. For example: 192.168.1.98:5000


7. If there is an error during operation, please provide a picture of the error message so that we can accurately solve your problem




If the above method does not work, please modify line 411 of the "camera_opencv. py" file in "adeept_raspclaws/server" to read "camera=cv2. VideoCapture (Camera. videos_source)" instead of "camera=cv2. VideoCapture (-1)"
Trying the above steps.


Best!

  ------------------------------------------
Adeept Tech Support Team
Adeept Technology Co., Ltd.
E-mail: support@adeept.com
Web: www.adeept.com





Reply

Use magic Report

You have to log in before you can reply Login | Sign Up

Points Rules